$re = '/(?!changelogs)(\d+)/mi';
$str = 'http://www.opera.com/docs/changelogs/unified/1215/
http://www.opera.com/security/advisory/1047
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);