package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)f+?(.*?)o+?(.*?)o+?(.*?)b+?(.*?)a+?(.*?)r+?(.*?)`)
var str = `foqwroqweabaasdwrwww`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}