re = /f+?(.*?)o+?(.*?)o+?(.*?)b+?(.*?)a+?(.*?)r+?(.*?)/m
str = 'foqwroqweabaasdwrwww'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end