using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms).*Description:\s(?<Description>.*).*Node:\s+(?<Node>.*).*Severity:\s+(?<Severity>.*)";
string input = @"Datum: 30 Sep 2022 10:36:02.379
Description: CPU seit 5 min bel 100%
Node: p01.r01.shp01
Severity: 1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}