$re = '/^(?:.*?[_ ])?v\.?(\d+(?:\.\d+)*[a-z]?)/mi';
$str = 'Title_v1_1.00.mov filters 1
v.1.0.1-Title.mp3 filters 1.0.1
Title V.3.4A. filters 3.4A
V3.0.4b mix v2 filters 3.0.4b
Title v1 V3.0.4b mix v2
v1
test v1
test_v1
testv1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);