# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:.*?[_ ])?v\.?(\d+(?:\.\d+)*[a-z]?)"
test_str = ("Title_v1_1.00.mov filters 1\n"
"v.1.0.1-Title.mp3 filters 1.0.1\n"
"Title V.3.4A. filters 3.4A\n"
"V3.0.4b mix v2 filters 3.0.4b\n\n"
"Title v1 V3.0.4b mix v2\n"
"v1\n"
"test v1\n"
"test_v1\n\n"
"testv1")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.