# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*-.*$\K|\s//gm;t' <<< "My Beautiful Video - Hello darling - 19.10.2015 10:00"