use strict;
my $str = 'My Beautiful Video - Hello darling - 19.10.2015 10:00';
my $regex = qr/\s*-.*$\K|\s/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";