package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\|(\w+)\|`)
var str = `This is a [#TEST#] of the |regular| expression to get |matches|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}