using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.promise[\r\n]+[\s]*\.then\(";
string input = @" .promise
.then(";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}