package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)\.promise[\r\n]+[\s]*\.then\(`)
var str = ` .promise
.then(`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}