use strict;
my $str = 'https://localhost/produkter/mun-tander/40/currentprice-asc/activesubstances_paracetamol/freefrom_Parabener/producttypemouthandteeth_Munsk%C3%B6lj/
https://localhost/produkter/mun-tander/40/currentprice-asc
https://localhost/produkter/mun-tander/40/currentprice-asc/
https://localhost/produkter/mun-tander/40/currentprice-asc/content/img/ios-icon.png
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/filter-activesubstances_paracetamol-freefrom_Parabener-producttypemouthandteeth_Munsk%C3%B6lj/
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/filter-activesubstances_paracetamol/filter-freefrom_Parabener/filter-producttypemouthandteeth_Munsk%C3%B6lj/
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/content/img/ios-icon.png
^(.*)\\/count-([0-9]+)\\/sortBy-([a-z]+)_([a-z]+)((\\/filter-[^\\/]+)+)?\\/?
^(.*)(\\/[0-9]+\\/[a-z]+_[a-z]+\\/?.*)\\/?$';
my $regex = qr/^(.*)(\/[0-9]+\/[a-z]+\-[a-z]+\/?.*)\/?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}