import re
regex = re.compile(r"^(.*)(\/[0-9]+\/[a-z]+\-[a-z]+\/?.*)\/?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("https://localhost/produkter/mun-tander/40/currentprice-asc/activesubstances_paracetamol/freefrom_Parabener/producttypemouthandteeth_Munsk%C3%B6lj/\n"
"https://localhost/produkter/mun-tander/40/currentprice-asc\n"
"https://localhost/produkter/mun-tander/40/currentprice-asc/\n"
"https://localhost/produkter/mun-tander/40/currentprice-asc/content/img/ios-icon.png\n"
"https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/filter-activesubstances_paracetamol-freefrom_Parabener-producttypemouthandteeth_Munsk%C3%B6lj/\n"
"https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/filter-activesubstances_paracetamol/filter-freefrom_Parabener/filter-producttypemouthandteeth_Munsk%C3%B6lj/\n"
"https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc\n"
"https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/\n"
"https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/content/img/ios-icon.png\n\n\n\n"
"^(.*)\\/count-([0-9]+)\\/sortBy-([a-z]+)_([a-z]+)((\\/filter-[^\\/]+)+)?\\/?\n\n"
"^(.*)(\\/[0-9]+\\/[a-z]+_[a-z]+\\/?.*)\\/?$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")