package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|[^+])(\+[^\s+.!]+)`)
var str = `Lorem ipsum +dolor ++sit +amet.
Lorem ipsum +dolor+sit amet.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}