re = /(?:^|[^+])(\+[^\s+.!]+)/m
str = 'Lorem ipsum +dolor ++sit +amet.
Lorem ipsum +dolor+sit amet.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end