import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\S+)>\\s*<(\\S+)>\\s*(?:\"(.+)\"|<(\\S+)>).*.";
final String string = "# started 2015-11-29T18:23:17Z\n\n"
+ "<http://dbpedia.org/resource/Bobcat_Company> <http://dbpedia.org/property/type> <http://dbpedia.org/resource/Subsidiary> .\n"
+ "<http://dbpedia.org/resource/Bobcat_Company> <http://dbpedia.org/property/website> <http://www.bobcat.com> .\n"
+ "<http://dbpedia.org/resource/Albedo> <http://dbpedia.org/property/colwidth> \"30\"^^<http://www.w3.org/2001/XMLSchema#integer> .\n"
+ "<http://dbpedia.org/resource/Anarchism> <http://dbpedia.org/property/voy> \"no\"@en .\n"
+ "<http://dbpedia.org/resource/Anarchism> <http://dbpedia.org/property/n> \"no\"@en .\n"
+ "<http://dbpedia.org/resource/Anarchism> <http://dbpedia.org/property/v> \"no\"@en .\n"
+ "<http://dbpedia.org/resource/Knight_Transportation> <http://dbpedia.org/property/keyPeople> \"Kevin Knight\"@en .\n"
+ "<http://dbpedia.org/resource/Knight_Transportation> <http://dbpedia.org/property/keyPeople> \"Keith Knight\"@en .\n"
+ "<http://dbpedia.org/resource/Knight_Transportation> <http://dbpedia.org/property/numEmployees> \"4400\"^^<http://www.w3.org/2001/XMLSchema#integer> .\n"
+ "<http://dbpedia.org/resource/Knight_Transportation> <http://dbpedia.org/property/industry> \"motor transportation-trucking\"@en .\n"
+ "<http://dbpedia.org/resource/Knight_Transportation> <http://dbpedia.org/property/products> \"truckload shipping\"@en .\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}