# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(\S+)>\s*<(\S+)>\s*(?:\"(.+)\"|<(\S+)>).*."
test_str = ("# started 2015-11-29T18:23:17Z\n\n"
"<http://dbpedia.org/resource/Bobcat_Company> <http://dbpedia.org/property/type> <http://dbpedia.org/resource/Subsidiary> .\n"
"<http://dbpedia.org/resource/Bobcat_Company> <http://dbpedia.org/property/website> <http://www.bobcat.com> .\n"
"<http://dbpedia.org/resource/Albedo> <http://dbpedia.org/property/colwidth> \"30\"^^<http://www.w3.org/2001/XMLSchema#integer> .\n"
"<http://dbpedia.org/resource/Anarchism> <http://dbpedia.org/property/voy> \"no\"@en .\n"
"<http://dbpedia.org/resource/Anarchism> <http://dbpedia.org/property/n> \"no\"@en .\n"
"<http://dbpedia.org/resource/Anarchism> <http://dbpedia.org/property/v> \"no\"@en .\n"
"<http://dbpedia.org/resource/Knight_Transportation> <http://dbpedia.org/property/keyPeople> \"Kevin Knight\"@en .\n"
"<http://dbpedia.org/resource/Knight_Transportation> <http://dbpedia.org/property/keyPeople> \"Keith Knight\"@en .\n"
"<http://dbpedia.org/resource/Knight_Transportation> <http://dbpedia.org/property/numEmployees> \"4400\"^^<http://www.w3.org/2001/XMLSchema#integer> .\n"
"<http://dbpedia.org/resource/Knight_Transportation> <http://dbpedia.org/property/industry> \"motor transportation-trucking\"@en .\n"
"<http://dbpedia.org/resource/Knight_Transportation> <http://dbpedia.org/property/products> \"truckload shipping\"@en .\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.