import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^NoticeText:(?:(?!\\nNoticeText:).)*\\n\\s+EventInfo(?:(?!\\nNoticeText:).)*\n"
+ "\\n\\s+Text\\s*\\[str\\]\\s*=\\s*\"([^\"]*)\"(?:(?!\\nNoticeText:).)*\\nNoticeText:(?:(?!\\nNoticeText:).)*\\n\\s+EventInfo(?:(?!\\nNoticeText:).)*\n"
+ "\\n\\s+Text\\s*\\[str\\]\\s*=\\s*\"([^\"]*)\"(?:(?!\\nNoticeText:).)*";
final String string = "NoticeText:\n"
+ " NoticeType [str] = USER_TYPING_ON\n"
+ " Text [str] = \"user is typing\"\n"
+ " EventInfo:\n"
+ " PartyId [int] = 2\n"
+ " EventType [str] = MESSAGE\n"
+ " UserNickname [str] = \"Michael\"\n"
+ " EventId [int] = 4\n"
+ " Text [str] = \"Hey, how are you?\"\n"
+ " MsgCheck [str] = NONE\n"
+ " TimeOffset [int] = 23\n"
+ " UserType [str] = AGENT\n"
+ "NoticeText:\n"
+ " NoticeType [str] = USER_TYPING_ON\n"
+ " EventInfo:\n"
+ " PartyId [int] = 1\n"
+ " EventType [str] = MESSAGE\n"
+ " UserNickname [str] = \"Bob Smith\"\n"
+ " EventId [int] = 6\n"
+ " Text [str] = \"I'm good, how are you?\"\n"
+ " MsgCheck [str] = NONE\n"
+ " TimeOffset [int] = 28\n"
+ " UserType [str] = CLIENT\n"
+ " MessageType [str] = \"text\"";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}