# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^NoticeText:(?:(?!\nNoticeText:).)*\n\s+EventInfo(?:(?!\nNoticeText:).)*
\n\s+Text\s*\[str\]\s*=\s*"([^"]*)"(?:(?!\nNoticeText:).)*\nNoticeText:(?:(?!\nNoticeText:).)*\n\s+EventInfo(?:(?!\nNoticeText:).)*
\n\s+Text\s*\[str\]\s*=\s*"([^"]*)"(?:(?!\nNoticeText:).)*
"""
test_str = ("NoticeText:\n"
" NoticeType [str] = USER_TYPING_ON\n"
" Text [str] = \"user is typing\"\n"
" EventInfo:\n"
" PartyId [int] = 2\n"
" EventType [str] = MESSAGE\n"
" UserNickname [str] = \"Michael\"\n"
" EventId [int] = 4\n"
" Text [str] = \"Hey, how are you?\"\n"
" MsgCheck [str] = NONE\n"
" TimeOffset [int] = 23\n"
" UserType [str] = AGENT\n"
"NoticeText:\n"
" NoticeType [str] = USER_TYPING_ON\n"
" EventInfo:\n"
" PartyId [int] = 1\n"
" EventType [str] = MESSAGE\n"
" UserNickname [str] = \"Bob Smith\"\n"
" EventId [int] = 6\n"
" Text [str] = \"I'm good, how are you?\"\n"
" MsgCheck [str] = NONE\n"
" TimeOffset [int] = 28\n"
" UserType [str] = CLIENT\n"
" MessageType [str] = \"text\"")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL | re.IGNORECASE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.