#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mx)^[ ]+(*SKIP)(*FAIL) # match spaces at the beginning of a line" & @CRLF & _
" # these shall fail" & @CRLF & _
"| # OR" & @CRLF & _
"[ ]{2,} # at least two spaces"
Local $sString = "One OS to rule them all," & @CRLF & _
" One OS to find them." & @CRLF & _
" One OS to call them all," & @CRLF & _
" And in salvation bind them." & @CRLF & _
" In the bright land of Linux," & @CRLF & _
" Where the hackers play."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)