import re
regex = re.compile(r"""
^[ ]+(*SKIP)(*FAIL) # match spaces at the beginning of a line
# these shall fail
| # OR
[ ]{2,} # at least two spaces
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("One OS to rule them all,\n"
" One OS to find them.\n"
" One OS to call them all,\n"
" And in salvation bind them.\n"
" In the bright land of Linux,\n"
" Where the hackers play.")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)