package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^9+((\.9+)+)?$`)
var str = `9
.9
9.
99
.9
9.9.9
99.99.
.99.99
99.999.999.99.9
9
9ad.99
.99.99
99.
^9+((\.9+)+)?$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}