const regex = /^9+((\.9+)+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^9+((\\.9+)+)?$', 'gm')
const str = `9
.9
9.
99
.9
9.9.9
99.99.
.99.99
99.999.999.99.9
9
9ad.99
.99.99
99.
^9+((\\.9+)+)?\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}