#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\G(?!^)|^(?=\d+\.\d+ \d+\.\d+ \d+(?:\.\d+)?(?: \d+)* \$\d))\s*\$?\K\d+(?:\.\d+)?"
Local $sString = "0.91 0.45 0.69 58 47 45 23 83 90 $595 NO IDL" & @CRLF & _
"output: array([0] => 0.91, " & @CRLF & _
" [1] => 0.45, " & @CRLF & _
" [2] => 0.69, " & @CRLF & _
" [3] => 58, " & @CRLF & _
" [4] => 47, " & @CRLF & _
" [5] => 45, " & @CRLF & _
" [6] => 23, " & @CRLF & _
" [7] => 83, " & @CRLF & _
" [8] => 90, " & @CRLF & _
" [9] => 595)" & @CRLF & _
"0.91 0.45 0.69 58 47 45 $595 NO IDL" & @CRLF & _
"output: array([0] => 0.91, " & @CRLF & _
" [1] => 0.45, " & @CRLF & _
" [2] => 0.69, " & @CRLF & _
" [3] => 58, " & @CRLF & _
" [4] => 47, " & @CRLF & _
" [5] => 45, " & @CRLF & _
" [5] => 595)" & @CRLF & _
"0.91 0.45 0.69 0.63 58 47 45 $595 NO IDL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")