import re
regex = re.compile(r"(?:\G(?!^)|^(?=\d+\.\d+ \d+\.\d+ \d+(?:\.\d+)?(?: \d+)* \$\d))\s*\$?\K\d+(?:\.\d+)?", flags=re.MULTILINE)
test_str = ("0.91 0.45 0.69 58 47 45 23 83 90 $595 NO IDL\n"
"output: array([0] => 0.91, \n"
" [1] => 0.45, \n"
" [2] => 0.69, \n"
" [3] => 58, \n"
" [4] => 47, \n"
" [5] => 45, \n"
" [6] => 23, \n"
" [7] => 83, \n"
" [8] => 90, \n"
" [9] => 595)\n"
"0.91 0.45 0.69 58 47 45 $595 NO IDL\n"
"output: array([0] => 0.91, \n"
" [1] => 0.45, \n"
" [2] => 0.69, \n"
" [3] => 58, \n"
" [4] => 47, \n"
" [5] => 45, \n"
" [5] => 595)\n"
"0.91 0.45 0.69 0.63 58 47 45 $595 NO IDL")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")