#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm:^{1.*?CU)(?-s:.*)"
Local $sString = "{1:F21CRESUS33XLIQ9590112170}{2:O1030747170228BNPAGB22XCIT95901121701702280629U}{3:{103:GLBH}}{4" & @CRLF & _
":20:PK836J9GD2HI7SWQ" & @CRLF & _
":23B:CRED" & @CRLF & _
":32A:170214USD2154,252" " & @CRLF & _
"50:ABNYUS33XXXX" " & @CRLF & _
"/1Jose Lugo" " & @CRLF & _
"/2931 Corte De Luna" " & @CRLF & _
"/3 Seattle" " & @CRLF & _
"/498104, United States" " & @CRLF & _
"59F:BPAHCUHHXXXX" " & @CRLF & _
"/1 Jossef Goldberg" " & @CRLF & _
"/21220 Bradford Way" " & @CRLF & _
"/3 Seattle" " & @CRLF & _
"/498104, United States" & @CRLF & _
":71A:OUR" " & @CRLF & _
"-}" " & @CRLF & _
"{1:L01BARCGB21X05G7115765182}{2:O1030946170226ABBYGB2LXXXX71157651821702261046S}{3:{103:WJHX}}{4"" & @CRLF & _
":20:YZDSKFJNXV4BE3MP" " & @CRLF & _
":23B:CRED" " & @CRLF & _
":32A:170214USD63362,31" " & @CRLF & _
"50:ABBYGB2LXXXX" " & @CRLF & _
"/1Jossef Goldberg" " & @CRLF & _
"/21220 Bradford Way" " & @CRLF & _
"/3 Seattle" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")