$re = '/(?sm:^{1.*?CU)(?-s:.*)/';
$str = '{1:F21CRESUS33XLIQ9590112170}{2:O1030747170228BNPAGB22XCIT95901121701702280629U}{3:{103:GLBH}}{4
:20:PK836J9GD2HI7SWQ
:23B:CRED
:32A:170214USD2154,252"
50:ABNYUS33XXXX"
/1Jose Lugo"
/2931 Corte De Luna"
/3 Seattle"
/498104, United States"
59F:BPAHCUHHXXXX"
/1 Jossef Goldberg"
/21220 Bradford Way"
/3 Seattle"
/498104, United States
:71A:OUR"
-}"
{1:L01BARCGB21X05G7115765182}{2:O1030946170226ABBYGB2LXXXX71157651821702261046S}{3:{103:WJHX}}{4"
:20:YZDSKFJNXV4BE3MP"
:23B:CRED"
:32A:170214USD63362,31"
50:ABBYGB2LXXXX"
/1Jossef Goldberg"
/21220 Bradford Way"
/3 Seattle" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);