import re
regex = re.compile(r"(CREATE TABLE.*?;)", flags=re.DOTALL | re.MULTILINE)
test_str = ("DROP TABLE IF EXISTS `aes_interval`;\n"
"CREATE TABLE `aes_interval` (\n"
" `processcode` bigint(20) NOT NULL,\n"
" `overstaying` int(11) NOT NULL,\n"
" `floating` int(11) NOT NULL,\n"
" PRIMARY KEY (`processcode`) USING BTREE\n"
") ENGINE = InnoDB CHARACTER SET = utf8 COLLATE = utf8_general_ci;\n"
"by running a RegEx that would select all in between (...) i will be able to get an output/substringed text like below:\n\n"
"CREATE TABLE `aes_interval` (\n"
" `processcode` bigint(20) NOT NULL,\n"
" `overstaying` int(11) NOT NULL,\n"
" `floating` int(11) NOT NULL,\n"
" PRIMARY KEY (`processcode`) USING BTREE\n"
");")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")