use strict;
my $str = 'pdf_of_filename_53613785621.183761237_127.10.10.0_8726347.xls';
my $regex = qr/^(.*)_[12]?\d{1,2}\.[12]?\d{1,2}\.[12]?\d{1,2}\.[12]?\d{1,2}_\d+\.([a-z]{3,4})$/ip;
my $subst = '\\1.\\2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";