$re = '/^(.*)_[12]?\d{1,2}\.[12]?\d{1,2}\.[12]?\d{1,2}\.[12]?\d{1,2}_\d+\.([a-z]{3,4})$/i';
$str = 'pdf_of_filename_53613785621.183761237_127.10.10.0_8726347.xls';
$subst = "\1.\2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;