import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((\\xf4)\\x65)\\2(\\x80)(\\4\\2))((\\2(\\x45\\5)\\x0A)(\\2\\x10\\3))(\\3(\\\\xf4\\4)\\2)$";
final String string = "ôeôe€€ôeôeE€ôe\n"
+ "ôeôô\\xf4€ôe";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}