$re = '/^(((\xf4)\x65)\2(\x80)(\4\2))((\2(\x45\5)\x0A)(\2\x10\3))(\3(\\\\xf4\4)\2)$/';
$str = 'ôeôe€€ôeôeE€ôe
ôeôô\\xf4€ôe';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);