// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\<link.+?rel=["']?(?:webmention|http\:\/\/webmention\.org\/?)['"]?.*?\>"#).unwrap();
let string = "<link rel=\"webmention\" href=\" \">
<link rel=\"http://webmention.org/\" href=\" \">
<link rel=\"webmention http://webmention.org/\" href=\" \">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}