# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<= \w|^\w|^) (?=\w |\w$|$)//gm;t' <<< "test abc abc 123 foo bar f f f
f boo
f boo
boo f
boo f f
too f "