#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<= \w|^\w|^) (?=\w |\w$|$)"
Local $sString = "test abc abc 123 foo bar f f f" & @CRLF & _
"f boo" & @CRLF & _
" f boo" & @CRLF & _
"boo f" & @CRLF & _
"boo f f" & @CRLF & _
"too f "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)