#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)PAN-OS\s*ver:\s*(?<PanOS_Version>\S+)\s*Panorama ver:\s*(?<Panorama_Version>\S+)"
Local $sString = "Panorama push to device:013101010578 for device-group: Durham_IPV6_INET_SVCS succeeded. JobId=2480530" & @CRLF & _
"" & @CRLF & _
"Panorama push to device:007257000068919 for device-group: Azure-China-Internet-North succeeded. JobId=2480524" & @CRLF & _
"" & @CRLF & _
"Panorama push to device:016401009013 for device-group: Austin_Experience_Lounge succeeded. JobId=2480530" & @CRLF & _
"" & @CRLF & _
"extracted. In the case of the above 3 examples, the 3 values extracted are "Durham_IPV6_INET_SVCS", "Azure-China-Internet-North" and "Austin_Experience_Lounge" respectively." & @CRLF & _
"" & @CRLF & _
"Client authentication successful PAN-OS ver: 9.1.11-h3 Panorama ver:10.1.6-h3 Client IP: 10.68.196.211 Server IP: 10.58.217.123 Client CN: 013101004861" "Client authentication successful PAN-OS ver: 9.1.11 Panorama ver:10.1.6-h6 Client IP: 10.58.90.53 Server IP: 10.58.90.200 Client CN: 010401005346"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")