import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "PAN-OS\\s*ver:\\s*(?<PanOS_Version>\\S+)\\s*Panorama ver:\\s*(?<Panorama_Version>\\S+)";
final String string = "Panorama push to device:013101010578 for device-group: Durham_IPV6_INET_SVCS succeeded. JobId=2480530\n\n"
+ "Panorama push to device:007257000068919 for device-group: Azure-China-Internet-North succeeded. JobId=2480524\n\n"
+ "Panorama push to device:016401009013 for device-group: Austin_Experience_Lounge succeeded. JobId=2480530\n\n"
+ "extracted. In the case of the above 3 examples, the 3 values extracted are \"Durham_IPV6_INET_SVCS\", \"Azure-China-Internet-North\" and \"Austin_Experience_Lounge\" respectively.\n\n"
+ "Client authentication successful PAN-OS ver: 9.1.11-h3 Panorama ver:10.1.6-h3 Client IP: 10.68.196.211 Server IP: 10.58.217.123 Client CN: 013101004861\" \"Client authentication successful PAN-OS ver: 9.1.11 Panorama ver:10.1.6-h6 Client IP: 10.58.90.53 Server IP: 10.58.90.200 Client CN: 010401005346";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}