package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]+\([^\)\(]+\)`)
var str = `translate(4 44) rotate(8 7 123)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}