$re = '/[a-z]+\([^\)\(]+\)/m';
$str = 'translate(4 44) rotate(8 7 123)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);