const regex = /(?i)(.*((\bown(er|re)\b)|(\bocc?up(eir|ier|ire)\b)s?).*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(.*((\\bown(er|re)\\b)|(\\bocc?up(eir|ier|ire)\\b)s?).*)', 'g')
const str = `customer_name
Miss. amber Lowe
Ms. zara scantlebury
Mrs. Jacky Kalonda
Mrs. Cynthia Williams
Mr. Suresh Kotecha
Rebecca Bormer
Mr. Affan Hashmi
Mr. William Dormand
Mr. Andrew MacIntosh
Mr. Kieran Ross
Mrs. rachel pezerovic
Mr. David Abbott
Mrs. Fazal Jan Butt
Owner Occupier
Mrs. Barbara Feerick
Mr. Gary Rendell
Mrs. Natalie Farrell
Ms. Sally Janani
Mr. Chris Tween
Mr. Shahid Ali
Mr. Govanmurad saifi
Ms. Vera Lucia
Nicola Smith
Mr. Andrew Jessop
Ashley Phoenix
Mrs. Rosalie Cross
Ms. Patricia Smith
Martin Stewart
Mr. zakir nazmin
Owner Occupier
Mr. Leeanne Jasper
Owner Occupier
. Mr Yousuf Munshi C/O Mrs Zulekhan Munshi
Owner Occupier
Miss. Gemma Johnson
Mr. Michael Brown
Owner Occupiers
Mr. paul atkins
Karen Taylor
Mr. Yusuf Hassan
Mrs Teresa Geeson
Mr. Paul Regan
Mrs Pat Robinson
Mr. Patrick Jones
Mrs. chapanben bava
Mr. Nadeem Tariq
Mr. Kiran Jayaprakash
Kris Henley
Mrs. Denise Gouge
Mr. Dilip Gurung
Owner Occupier
Miss Stephanie Hamman
Mr. Richard Sneddon
Mr. AvtarSingh Chauhan
Mr. Simon Smithen
Owner Occupier
Mr. Hussein Hydari
Mr. kirk wragg
Mr. Melvyn Orton
Mr. Derrick Moy
Miss. Jade Rogers
Mr. Adam Farnen
Mr. Mohammad Hossain
Lauran Kilpatrick
Mr. Dennis Buffrey
Mr. Bruce Jones
Mr. Phillip Christey
Christine Searle
Mr. Timothy Shaw
Mrs. yijia liu
Mr. Barry Nell
Mrs. Caroline Rabaiotti
Owner Occupier
Mrs. Hazel Bell
Craig Barrow
Mr. Mani Dhaliwal
Mr. Linda Maynard
Mrs. Amanda Jooma
Mr. eamon monaghan
Victoria Fairbourne
Mrs. Tasleem Akhtar
Mrs. Cheryl Woollett
Mr. Alexander Smith
Mrs. jane beaumont
Mr. david fergusson
Mr. Masood Ahmed
Clare Turner
Owner Occupier
Mr. Malcolm Hutchinson
Jim Stobo
Mr. richard upton
Mr. David Canvin
Miss. Nicola Carlin
Mr. Jason Kingsley
Mr Michael Sangster
Christopher Hill
Mrs. Balvinder Brar
Miss. Donna Walsh
Mark Armstrong
Miss. Ade Robinson Oshodi
owner occupier
Mr. CARE OF Lauristons
Owner Occupier
Mr. david Riley`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}