# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(.*((\bown(er|re)\b)|(\bocc?up(eir|ier|ire)\b)s?).*)"
test_str = ("customer_name\n"
"Miss. amber Lowe\n"
"Ms. zara scantlebury\n"
"Mrs. Jacky Kalonda\n"
"Mrs. Cynthia Williams\n"
"Mr. Suresh Kotecha\n"
"Rebecca Bormer\n"
"Mr. Affan Hashmi\n"
"Mr. William Dormand\n"
"Mr. Andrew MacIntosh\n"
"Mr. Kieran Ross\n"
"Mrs. rachel pezerovic\n"
"Mr. David Abbott\n"
"Mrs. Fazal Jan Butt\n"
"Owner Occupier\n"
"Mrs. Barbara Feerick\n"
"Mr. Gary Rendell\n"
"Mrs. Natalie Farrell\n"
"Ms. Sally Janani\n"
"Mr. Chris Tween\n"
"Mr. Shahid Ali\n"
"Mr. Govanmurad saifi\n"
"Ms. Vera Lucia\n"
"Nicola Smith\n"
"Mr. Andrew Jessop\n"
"Ashley Phoenix\n"
"Mrs. Rosalie Cross\n"
"Ms. Patricia Smith\n"
"Martin Stewart\n"
"Mr. zakir nazmin\n"
"Owner Occupier\n"
"Mr. Leeanne Jasper\n"
"Owner Occupier\n"
". Mr Yousuf Munshi C/O Mrs Zulekhan Munshi\n"
"Owner Occupier\n"
"Miss. Gemma Johnson\n"
"Mr. Michael Brown\n"
"Owner Occupiers\n"
"Mr. paul atkins\n"
"Karen Taylor\n"
"Mr. Yusuf Hassan\n"
"Mrs Teresa Geeson\n"
"Mr. Paul Regan\n"
"Mrs Pat Robinson\n"
"Mr. Patrick Jones\n"
"Mrs. chapanben bava\n"
"Mr. Nadeem Tariq\n"
"Mr. Kiran Jayaprakash\n"
"Kris Henley\n"
"Mrs. Denise Gouge\n"
"Mr. Dilip Gurung\n"
"Owner Occupier\n"
"Miss Stephanie Hamman\n"
"Mr. Richard Sneddon\n"
"Mr. AvtarSingh Chauhan\n"
"Mr. Simon Smithen\n"
"Owner Occupier\n"
"Mr. Hussein Hydari\n"
"Mr. kirk wragg\n"
"Mr. Melvyn Orton\n"
"Mr. Derrick Moy\n"
"Miss. Jade Rogers\n"
"Mr. Adam Farnen\n"
"Mr. Mohammad Hossain\n"
"Lauran Kilpatrick\n"
"Mr. Dennis Buffrey\n"
"Mr. Bruce Jones\n"
"Mr. Phillip Christey\n"
"Christine Searle\n"
"Mr. Timothy Shaw\n"
"Mrs. yijia liu\n"
"Mr. Barry Nell\n"
"Mrs. Caroline Rabaiotti\n"
"Owner Occupier\n"
"Mrs. Hazel Bell\n"
"Craig Barrow\n"
"Mr. Mani Dhaliwal\n"
"Mr. Linda Maynard\n"
"Mrs. Amanda Jooma\n"
"Mr. eamon monaghan\n"
"Victoria Fairbourne\n"
"Mrs. Tasleem Akhtar\n"
"Mrs. Cheryl Woollett\n"
"Mr. Alexander Smith\n"
"Mrs. jane beaumont\n"
"Mr. david fergusson\n"
"Mr. Masood Ahmed\n"
"Clare Turner\n"
"Owner Occupier\n"
"Mr. Malcolm Hutchinson\n"
"Jim Stobo\n"
"Mr. richard upton\n"
"Mr. David Canvin\n"
"Miss. Nicola Carlin\n"
"Mr. Jason Kingsley\n"
"Mr Michael Sangster\n"
"Christopher Hill\n"
"Mrs. Balvinder Brar\n"
"Miss. Donna Walsh\n"
"Mark Armstrong\n"
"Miss. Ade Robinson Oshodi\n"
"owner occupier\n"
"Mr. CARE OF Lauristons\n"
"Owner Occupier\n"
"Mr. david Riley")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.