$re = '/(?![0-9.]+[a-z])(\+|-)?([0-9]+)(\.[0-9]+)?/';
$str = '15000.53=1254b+21';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);