// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<item (.*)(Misc\/)(\d*)_(\w*)_(\d*)(.*)(\w*) id="([^*])(\d*)(.+)_(\d+)(\w*)(.*")(.*=")(\w*)(.*)" \/>"#).unwrap();
let string = "<item href=\"Misc/9781620025420_epub3_001.smil\" id=\"x9781620025420_epub3_001.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_001.smil\" id=\"x9781620025420_epub3_001.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_002.smil\" id=\"x9781620025420_epub3_002.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_003.smil\" id=\"x9781620025420_epub3_003.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_004.smil\" id=\"x9781620025420_epub3_004.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_005.smil\" id=\"x9781620025420_epub3_005.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_006.smil\" id=\"x9781620025420_epub3_006.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_007.smil\" id=\"x9781620025420_epub3_007.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_008.smil\" id=\"x9781620025420_epub3_008.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_009.smil\" id=\"x9781620025420_epub3_009.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_010.smil\" id=\"x9781620025420_epub3_010.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_011.smil\" id=\"x9781620025420_epub3_011.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_012.smil\" id=\"x9781620025420_epub3_012.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_013.smil\" id=\"x9781620025420_epub3_013.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_014.smil\" id=\"x9781620025420_epub3_014.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_015.smil\" id=\"x9781620025420_epub3_015.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_016.smil\" id=\"x9781620025420_epub3_016.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_017.smil\" id=\"x9781620025420_epub3_017.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_018.smil\" id=\"x9781620025420_epub3_018.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_019.smil\" id=\"x9781620025420_epub3_019.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_020.smil\" id=\"x9781620025420_epub3_020.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_021.smil\" id=\"x9781620025420_epub3_021.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_022.smil\" id=\"x9781620025420_epub3_022.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_023.smil\" id=\"x9781620025420_epub3_023.smil\" media-type=\"text/plain\" />
<item href=\"Misc/9781620025420_epub3_024.smil\" id=\"x9781620025420_epub3_024.smil\" media-type=\"text/plain\" />";
let substitution = "<item \\1\\2\\3\\4_\\5.\\6 id=\"\\7\\8\\9_\\10\\11\\12\\13\\14\\15\\16\\17";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}