package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[^?:\).{0,}](.+)`)
var str = `)asdasdasads1212312314564561425346152435621456@@@@@`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}