$re = '/[^?:\).{0,}](.+)/i';
$str = ')asdasdasads1212312314564561425346152435621456@@@@@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);