const regex = /201\d\.(?<Month>\w*)\d\d\-/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('201\\d\\.(?<Month>\\w*)\\d\\d\\-', 'gms')
const str = `<h2 class="align-center title-green">A 2016.
június 15-i, 356. sorsolás
eredménye</h2>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}