import re
regex = re.compile(r"201\d\.(?<Month>\w*)\d\d\-", flags=re.MULTILINE | re.DOTALL)
test_str = ("<h2 class=\"align-center title-green\">A 2016.\n"
" június 15-i, 356. sorsolás\n"
"eredménye</h2>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")