const regex = /^\+?(\d[.\- ]*){9,12}(e?xt?\d{1,5})?$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?(\\d[.\\- ]*){9,12}(e?xt?\\d{1,5})?$', 'gim')
const str = `+91 9970464878
+91-22-22221500
09970464878
9970464878`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}