$re = '/^\+?(\d[.\- ]*){9,12}(e?xt?\d{1,5})?$/im';
$str = '+91 9970464878
+91-22-22221500
09970464878
9970464878';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);