use strict;
my $str = '2222233333,34';
my $regex = qr/(\d)(?=(?:\d{3})+(?!\d))/p;
my $subst = '$1.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";